Вы не вошли.

Уважаемый гость, добро пожаловать на форум: CRYMOD.NET - Портал сообщества CryENGINE. Если вы здесь впервые, то, пожалуйста, прочитайте раздел Помощь. В этом разделе можно подробно ознакомится с функционалом данной системы. Что бы использовать все возможности системы, необходимо зарегистрироваться. Для этого пройдите по ссылке и узнайте подробнее о процессе регистрации. В случае если вы уже зарегистрировались – войдите под своей учётной записью.

1

Воскресенье, 8 Апрель 2018, 15:38

Беда с отображением полигонов

Всем привет, господа! Может кто уже встречался с такой проблемой? Переносим модель в движок - а на ней не отображаются все полигоны. Особенно в деревьях. Сейчас подробнее поясню. Вот у нас есть деревце. У него есть ствол (отображается нормально) и листва. В 3Д Максе листва выглядит красиво и хорошо, видно полноценное дерево (скриншот 1). Переносим в движок и видим: ствол есть, а с листвой ну просто беда (скриншот 2). Кое-где листва действительно торчит, но в большинстве полигонов сетка полигонов видна, а самой листвы в ней нет. Можно сказать: дак это ж просто фиксится! Иди себе в Material Editor, ставь 2 sided material и всё! Но это, я считаю, не вариант, поскольку в стандартных деревьях движка 2 sided material не используется вообще, да и к тому же если его поставить - полигоны, которые он заполняет - темнее, чем обычная листва, в силу этого - каждый полигон листвы отбрасывает тень на другой полигон, от этого дерево в одном месте выглядит светлее - в другом - темнее. Как можно или можно ли вообще избавится от такого рода проблемы?


Ссыль на злополучные деревья: [вложением, либо прямой ссылкой на рекомендуемый хостинг]