Вы не вошли.

1

Понедельник, 2 Октябрь 2017, 18:04

Где в Cryengine 5 находится lod generator?

Один простой вопрос, куда хитропопые немцы засунули генератор лодов в Cryengine 5?? искал через поиск в двигле, не находит, может название поменяли инструменту??

3

Вторник, 3 Октябрь 2017, 04:32



Либо это меня так штырит что я его не вижу, либо движок решил поиграть со мной в игру, вот скажите, я ведь не один тут ничего не вижу?:
п.с. версия 5.3
MugGod приложил следующее изображение:
  • noLodG.jpg

4

Вторник, 3 Октябрь 2017, 09:15

Либо это меня так штырит что я его не вижу
Учитывая, что ты снимал на телефон вместо использования нормального Принтскрина, то осмелюсь предположить, что да - это тебя так штырит. Это первое.

Второе. Разве все нормальные люди не делают ЛОДы в Максе ещё во время создания основных моделей?

Третье. Я конечно уже не хочу связываться с Краем, но стало интересно, и краем глаза глянул в алексовскую ссылку. Так вот, насколько я понял после прочтения первого абзаца, этот генератор работает только со статичной геометрией, но не с динамичной. Стало быть, для динамичных объектов всё равно придётся ваять ЛОДы вручную. А раз так, раз с этим всё равно придётся связываться, то может тогда и для статики всё вручную нормально забацать? Если не прав - поправьте меня.

5

Среда, 4 Октябрь 2017, 14:01

Либо это меня так штырит что я его не вижу
Учитывая, что ты снимал на телефон вместо использования нормального Принтскрина, то осмелюсь предположить, что да - это тебя так штырит. Это первое.

Второе. Разве все нормальные люди не делают ЛОДы в Максе ещё во время создания основных моделей?

Третье. Я конечно уже не хочу связываться с Краем, но стало интересно, и краем глаза глянул в алексовскую ссылку. Так вот, насколько я понял после прочтения первого абзаца, этот генератор работает только со статичной геометрией, но не с динамичной. Стало быть, для динамичных объектов всё равно придётся ваять ЛОДы вручную. А раз так, раз с этим всё равно придётся связываться, то может тогда и для статики всё вручную нормально забацать? Если не прав - поправьте меня.



Ну просто я пользуюсь только мобильным интернетом, вот и снял на телефон, чтоб с пк на телефон не переносить, плюс у меня type-c кабель всего один, и искать его в тот момент что бы перенести на телефон скрин... "сложнааа", а нормальный инет я не юзаю ибо Якутия, интернет только у боярин и на предприятиях, вот так вот:) а по поводу того зачем мне лод генератор я промолчу, просто надо

6

Четверг, 5 Октябрь 2017, 03:53

Последнее обновление 21 сентября 2017, там написано наверху:

Цитата

LOD Generator in CRYENGINE 5.4 will not work properly with Vulkan APIs. It is recommended to use the existing rendering pipeline.

Цитата

Генератор LOD в CRYENGINE 5.4 не будет работать должным образом с API-интерфейсом Vulkan. Рекомендуется использовать существующий пайплайн (т.е. дедовский метод).

7

Четверг, 5 Октябрь 2017, 09:53

Vulkan API
Вот читаю в Вике:

Цитата

Vulkan API изначально был известен как «новое поколение OpenGL» или просто «glNext», но после анонса компания отказалась от этих названий в пользу названия Vulkan[4]. Как и OpenGL, Vulkan позволяет с высокой производительностью отображать в реальном времени различные приложения с 3D-графикой, такие как игры или интерактивные книги на всех платформах, а также обеспечивает более высокую производительность и меньшую нагрузку на процессор, аналогично Direct3D 12 и Mantle. Vulkan основан на технологиях AMD в Mantle

Правильно ли я понимаю, что СЕ в своей основе имеет этот самый Vulkan API?

8

Четверг, 5 Октябрь 2017, 10:01

Теперь есть поддержка, это просто очередной рендерер.

9

Пятница, 6 Октябрь 2017, 01:20

Теперь есть поддержка
То есть, чтобы создавать игры на СЕ 5.4, а игрокам, соответственно, играть в эти игры, Vulkan не обязателен?

10

Пятница, 6 Октябрь 2017, 14:01

Последнее обновление 21 сентября 2017, там написано наверху:

Цитата

LOD Generator in CRYENGINE 5.4 will not work properly with Vulkan APIs. It is recommended to use the existing rendering pipeline.

Цитата

Генератор LOD в CRYENGINE 5.4 не будет работать должным образом с API-интерфейсом Vulkan. Рекомендуется использовать существующий пайплайн (т.е. дедовский метод).


Да да я видел это предупреждение, только вот как я понял вулкан только в 5.4 появился, а у меня 5.3, так что это врятли из-за VulkanAPI

Это сообщение было отредактировано 1 раз(а), последнее редактирование в "MugGod" (6 Октябрь 2017, 14:08)